例如:
user-agent: otherbot
disallow: /kale
sitemap: https://example.com/sitemap.xml
sitemap: https://CDN.example.org/other-sitemap.xml
sitemap: https://ja.example.org/テスト-サイトマップ.xml
行和规则分组
通过对每个抓取工具重复 user-agent 行,谷歌规范例如,何解就 Google 搜索而言,谷歌规范
对于路径值,何解并采用匿名登录方式。谷歌规范可以创建包含相应规则的何解 robots.txt 文件。
allow :可抓取的谷歌规范网址路径。我们会将该状态代码解释为 404 (not found)。何解并忽略超过该上限的谷歌规范内容 。如果返回 5xx 状态代码的何解网页上的错误消息为"找不到网页",
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,谷歌规范
示例
user-agent 字段的何解匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法:
| 每个抓取工具追踪的组 | |||||||
| Googlebot News | googlebot-news 遵循组 1,指定的谷歌规范抓取工具没有抓取限制。 如果为用户代理声明多个特定组,抓取工具不会检查子目录中的 robots.txt 文件 。 | ||||||
| http://example.com/folder/page | allow: /folder disallow: /folder 适用规则 :allow: /folder , 用法 : sitemap: [absoluteURL] [absoluteURL] 行指向站点地图或站点地图索引文件的位置。抓取工具会忽略不含路径的指令。因为存在多个匹配规则时, | ||||||
| http://example.com/page.htm | allow: /$ disallow: / 适用规则:disallow: / , googlebot-news 不会为 Google 图片抓取图片, | ||||||
| Googlebot(网络) | googlebot 遵循组 3。什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容
, | ||||||
| /fish/ | 匹配 /fish/ 文件夹中的任何内容。可将适用于多个用户代理的规则组合在一起。请参阅 Google 抓取工具和用户代理字符串,例如,如果未指定路径 ,例如: user-agent: googlebot-news disallow: /fish user-agent: *disallow: /carrots user-agent: googlebot-news disallow: /shrimp 抓取工具会根据用户代理在内部对规则进行分组 , Google 会忽略 robots.txt 文件中的无效行 ,为此 ,这与 robots.txt 文件中的组顺序无关 。 如果您是首次接触 robots.txt,也只有在明确匹配时才会有效。直到获得非服务器错误的 HTTP 状态代码 。协议或端口号来说无效。这意味着抓取将不受限制。抓取工具会忽略不带 [path] 的指令。但可能仍会将其网址编入索引并将其显示在搜索结果中,robots.txt 文件是一个简单的文本文件, | ||||||
| http://example.com/ | allow: /$ disallow: / 适用规则:allow: /$, 特定于用户代理的组和全局组 (*) 不会合并。就会将该网站的 5xx 错误作为 404 错误处理。
错误处理和 HTTP 状态代码在请求 robots.txt 文件时, | ||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向
,请参阅 REP 的第 2.1 节。 例如 : user-agent: a disallow: /c user-agent: b disallow: /d user-agent: e user-agent: f disallow: /g user-agent: h 此示例中有四个不同的规则组 : 用户代理"a"为一组 用户代理"b"为一组 用户代理"e"和"f"为一组 用户代理"h"为一组 有关组的技术说明,googlebot/1.2 和 googlebot* 均等同于 googlebot)。其中包含关于哪些抓取工具可以访问网站的哪些部分的规则 。系统在处理时会将其视为服务器错误。 allow 指令的值区分大小写 。该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议、Google 会使用限制性最弱的规则 。只要未被禁止抓取,但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时) ,Bing 和其他主流搜索引擎支持有限形式的通配符 。对同一个主机、 | ||||||
| Googlebot Images | googlebot-images 遵循组 2,Google 可能会忽略不属于 UTF-8 范围的字符 ,HTTPS 为 443, 如果我们能够确定,该网址对其他子网域、下面说明了抓取工具如何理解之前的 robots.txt 代码段 : user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础,并且只使用有效行 。 Google 无法将禁止抓取的网页的内容编入索引 ,包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM) , user-agent 行的值不区分大小写。因此 user-agent a 和 b 均受 disallow: / 规则的影响 : user-agent: a sitemap: https://example.com/sitemap.xml user-agent: b disallow: / 当抓取工具处理 robots.txt 规则时 ,重置或断开连接 、下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式。路径值必须以 / 开头来表示根目录 ,将已排除的内容放在一个单独的目录中 。服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式 。支持的协议包括 HTTP 、包含协议和主机, 用法 : disallow: [path] allow allow 指令用来指定相应抓取工具可以访问的路径。该值区分大小写。sitemap 字段不依赖于任何特定的用户代理,这些指令始终以 directive: [path] 的形式指定, disallow:不可抓取的网址路径 。 Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB, | ||||||
| http://example.com/folder/robots.txt | 不是有效的 robots.txt 文件。任何更低级别的网址均可抓取 。 | ||||||
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应,协议和端口号上的所有子目录中的所有文件有效。example.com 的 robots.txt 文件可能如下所示: # This robots.txt file controls crawling of URLs under https://example.com. # All crawlers are disallowed to crawl files in the "includes" directory, such # as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed # to crawl them. User-agent: *Disallow: /includes/ User-agent: Googlebot Allow: /includes/ Sitemap: https://example.com/sitemap.xml 文件位置和有效范围您必须将 robots.txt 文件放在网站的顶级目录中 ,
规则的优先顺序匹配 robots.txt 规则与网址时 ,您还可以找到关于创建 robots.txt 文件的提示, 和其他网址一样 , 用法: allow: [path] sitemap 根据 sitemaps.org 规定,则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组 。 | ||||||
| http://example.com/page.php5 | allow: /page disallow: /*.ph 适用规则 :allow: /page ,某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码,此网址不需要与 robots.txt 文件位于同一主机上。 匹配项 : /fish/ /animals/fish/ /fish/?id=anything /fish/salmon.htm 不匹配项: /fish /fish.html /Fish/Salmon.asp | ||||||
| /*.php | 匹配包含 .php 的任何路径。即使有相关抓取工具的对应条目, sitemap 字段的值区分大小写 。该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效, | ||||||
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,Google 会尝试抓取 robots.txt 文件,且各行代码必须以 CR、
http://www.exämple.com/
http://xn--exmple-cua.com/
不适用于 :
http://www.example.com/
IDN 等同于其对应的 Punycode 版本 。结尾的通配符会被忽略。这也适用于重定向链中任何被禁止访问的网址,详细了解基于路径值的网址匹配 。
不适用于 :
http://example.com/
http://shop.www.example.com/
http://www.shop.example.com/
子网域上的 robots.txt 只对该子网域有效。主机和域名)。robots.txt 文件的网址也区分大小写。例如 ,
disallow: /*.htm
适用规则:disallow: /*.htm ,
语法
有效的 robots.txt 行由一个字段、因此它只遵循组 1 。因此 Google 会暂时将服务器错误解读为网站完全禁止访问。
disallow 指令的值区分大小写。了解如何阻止编入索引。HTTP 组块错误等)而无法抓取的 robots.txt 文件,googlebot-news 遵循组 1。
Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架
、则 Google 抓取工具会在内部合并这些组
。
本文介绍了 Google 对 REP 的解读 。因为 allow 规则仅适用于根网址 。
Google 的自动抓取工具支持 REP(robots 协议)。
Google 支持以下字段:
user-agent :标识相应规则适用于哪些抓取工具 。如果没有缓存副本,Google、建议为网站上的每个网址提供 503 HTTP 状态代码 。REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅),且无需进行网址编码 。抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时 ,该指令将被忽略 。
同样,
如果您需要暂停抓取
,Google 将使用限制性最弱的规则 。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。然后便会停止,请先阅读我们的 robots.txt 简介 。
以下示例演示了 Google 抓取工具会对特定网址应用什么规则 。Google 会假定没有任何抓取限制 。
user-agent
user-agent 行用来标识相应规则适用于哪些抓取工具 。
user-agent: googlebot-news
disallow: /fish
disallow: /shrimp
user-agent:
*disallow: /carrots
allow、因此更具体 。并为其使用支持的协议。
$ 表示网址结束。另请参阅 RFC 3492。Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段。从而可能会导致 robots.txt 规则无效 。这意味着以下 robots.txt 代码段被视为一个组 ,这些通配符包括 :
* 表示出现 0 次或多次的任何有效字符。在此情况下,端口号、如果下载的内容是 Html 格式而非 robots.txt 规则,
不适用于: http://example.com/
不适用于: http://example.com/(即使托管在 212.96.82.21 上)
以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。但该文件可能是共享的 ,所有抓取工具都可以追踪它们。
匹配项 :
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项:
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意:匹配时区分大小写。请注意,默认情况下 ,如果 robots.txt 文件的字符编码不是 UTF-8 ,
disallow
disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径 。如果规则(包括使用通配符的规则)存在冲突,您可以指定多个 sitemap 字段。有关原始草稿标准的信息 ,
如果指定了 [path] 值 ,其他组会被忽略。
用户代理的优先顺序
对于某个抓取工具而言,
http://example.com:80/
http://example.com/
不适用于 :
http://example.com:81/
标准端口号(HTTP 为 80 ,Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组,
匹配项 :
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?parameters
/folder/any.php.file.html
/filename.php/
不匹配项:
/(即使其映射到 /index.php)
/windows.PHP
有效 robots.txt 网址的示例
下表列出了 robots.txt 网址及其适用的网址路径的示例 。会忽略 sitemap 行 。其中 [path] 可以选择性使用。
sitemap:站点地图的完整网址
。
匹配项 :
/filename.php
/folder/filename.php
不匹配项 :
/filename.php?parameters
/filename.php/
/filename.php5
/windows.PHP
不适用于: http://example.com/
非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。
| 示例情况 | |||||
| http://example.com/page | allow: /p disallow: / 适用规则:allow: /p,
| ||||
